任务制作核心内容

总编：Pzy 愛國者之熱血 蜘蛛星云

本手册主要搜集了各任务制作者的创意以及一些知道的人比较少的技巧

主要适用于尤里的复仇

中国红警联盟总群：49345610

联系方式：AGZZRX@qq.com

如果有任何任务的创意，可以向联系方式里的邮箱投稿。

本工具书的各项教程由原创者亲自研究提供。如有雷同，纯属巧合。

本手册不注明作者的内容皆为手册编辑提供，请不要擅自修改本手册的内容，复制本工具书的内容请注明。

本手册若侵犯了您的某些权力，请联系上面的邮箱。

本手册版权属中国红警联盟，不得盗版。


触发

触发及其标签的关系

在工具栏的编辑选项下有 [image] 这两个选项，触发相信大家都很熟悉了。标签是什么呢？

标签就像一个连接电脑和音响的电线，将音响的功能使用，需要把它的电线连接上电脑。

其实，我们在把触发关联（将一个东西和另一个东西接到一起）到单位或建筑上的时候，是把这个触发的标签关联上了。而不是触发。

每建立一个触发，地图编辑器会自动给你一个标签。标签决定了关联的触发的类型——只触发一次，被关联者条件全部满足，重复触发——以及是否可以关联到单位或建筑上。

在上图可以看到，触发的名称是01000000，它的标签则是01000001。这是你用地图编辑器建立一个触发后的情况。但是编辑器建立的触发无法做到这样的情况：

一个标签关联无数个触发，或者一个触发关联到许多标签。

那么我们先来了解一下这样有什么用。

一个标签如果关联了许多个触发，那么这许多个触发都被关联到这一个标签上了。（废话……）

这就代表着一个标签关联到某个建筑上，相当于这许多个触发都被关联到这个建筑上了。如何呢？

如果这些触发条件分别是：被游戏者选中，首次受损，被任何事物摧毁。那么这三个条件都可以从这个建筑上表现出来。

如果一个触发分别关联到许多标签上，那么它就像被分成了几个触发，只不过根据标签的不同，类型不一样，关联到的单位不一样罢了。

不过这样做没有什么实际意义，你完全可以多造几个触发替代之。

触发类型有三种，人们所了解的大都只是两种，一个是触发一次（0），一个是重复触发（2）。相信大家都很明白这是什么意思。

那么还有一种 被关联物体全部满足条件（1）。在触发编辑器里只有0和2两种，1没有。在标签里1被写上“未知”。这就是编辑器问题了。

1的用途实际是：例如一个触发是被任何事物摧毁，事件触发，不论类型是0还是2，你把他关联到两个单位上，只要其中任意一个被摧毁就可以完成触发。

但是如果触发类型是1，那么必须被关联的两个单位都被摧毁才能触发。也就是被关联的单位全部满足条件才能触发。但是如果你用的条件不是可以关联到单位上的，那么这个触发就废了，不能触发。

现在鄙人验证了触发条件1进入事件不能使用触发类型1。

赛特大师的任务《月光宝盒》中，有一队一队的怪物在某个地点，被全部摧毁则会重新出现。但是赛特大师确用的是每一队怪物都是不同国家，这导致了不同怪点的怪是相互敌对的。

其实没必要如此，了解一下触发类型的类型1 被关联单位全部满足条件“被全部摧毁”就可以刷出新的一队怪物。

下面是把多个触发关联到一个标签上的教程：无限关联触发。

无限关联触发（第一种-均可触发）

1：想要关联的触发主要触发必须为重复触发（第一个触发）

2：在某个触发执行以后，禁止这个触发本身（54禁止目标触发）

3：每个触发通过“关联触发”进行串联。

主要触发：就是你第一个设置的触发，唯一关联到目标的触发。

附属触发：其他关联主要触发的触发。

关联方式

A关联B

B关联C

C关联D

……

n-1关联n

n不需关联触发。

无限关联触发（第二种-只有一个触发）

基本跟类型1一样，只不过主要触发不需要重复，每一个触发不需要再禁止掉自己了。

这样的效果就是，关联到某处的触发只有一个可执行，即某一个触发运行，其他触发将不会执行了。

随机触发

用多个触发同时进行“51 随机流逝时间”，哪个先运行就禁止其他的。就能做到随机触发。

当然可以用一组触发来防止两个同时运行。

此效果可以做到随机出现某种情况。

隐藏触发

一般都不可用……

59——减少特定路径点周围的矿石。可用

92——启动某一作战方的烈火风暴防御系统。

93——关闭某一作战方的烈火风暴防御系统。

94——在特定的路径点实施离子炮打击。

96——在特定的路径点实施化学导弹打击。

43——将一陨星发送到特定的单元。可用

44——启动离子风暴，按顺序去年特定数目的游戏画面(帧)。

45——结束离子风暴进程。

有两个未翻译的触发，是不能用的。91 Go Berzerk（发狂？）和97 Toggle Train Cargo（切换火车货物？）

（联盟版编辑器触发已修正）

13 流逝时间 和 47 流失剧情的时间的区别

首先，做一个这样的测试：

触发1（允许）：流逝时间6→播放文本123 & 允许目标触发2

触发2（禁止）：流失剧情时间5→播放文本333

你会发现，游戏开始6秒后，123和333都播放了。

聪明的你肯定明白了吧。

即使用了“47 流失剧情的时间”这个触发被禁止，时间也是在流失的。另一个触发允许他的时候，如果5秒已经过了，那么这个文本会立即播放。

全局变量

    全局变量在触发编辑器里面拥有相应的条件与动作。

开启全局变量以后，在以后的任务中也是开启的，只要你没有关闭。可以做到玩家表现不同，以后的任务不同。

新增全局变量在rules里，在[VariableNames]里注册，只需注册就行。

Rules原本的全局变量设置。这里是尤里的复仇规则文件。

播放音效注意事项

98 播入音效(随机路径点) 99 播放音效...

这两个触发不需要选择重复触发，启动以后即在路径点不停播放这个音效，间隔时间随机。

116 音乐停止于

触发名称貌似不对，这个触发可以停止在某个路径点播放的音效。

（联盟版编辑器触发项说明已更正）

雷达事件

0、3、4红色

1、2黄色

5蓝色

（联盟版编辑器触发项有说明）

箱子

触发108 建立小木箱 的数值

0=金钱

1=随机单位（可在rules.ini中设置）

2=修复所有建筑和部队

3=旧的隐形效果(仅仅是效果，没有实际意义）

4=爆炸

5=人员灭亡

6=金钱（少一些）

7=黑暗，用迷雾遮掩整个地图

8=显示整个地图

9=护甲加强

10=速度加快

11= 攻击力加强

12=一次核弹使用权

14=等级提升

16=气体弹头攻击（有一定伤害值）

17= 随机矿藏

在地图编辑器的特殊&覆盖里也有小木箱，不过只给钱。

要注意，小木箱只要存档再载入一次就会消失。

（联盟版编辑器触发项有说明）


地形

电梯建筑

让一个单位从悬崖下进入这个建筑，从建筑里出来就到了悬崖上面：

→ [image] →

就是这样。

条件：在玩家看来竖着的悬崖下，放一个长条建筑，这个建筑要有最下角在悬崖里。

如图，这个占地六个格的建筑，有一格在悬崖上（涂色的）。这样进入了步兵，再出来就会出现在悬崖上。不过别想原地下去了……

必须是如图的长条形状建筑，不然的话可能无法进入士兵。

绘制地形诀窍

地形→隐藏地形地块

可以隐藏悬崖（点一下悬崖，整个地图的悬崖都被隐藏了。）：

这样绘制悬崖会很方便。如何方便不好用语言解释，自己试试就知道了。

可以用

地形→显示每个地块

来显示被隐藏的地形。千万不要忘了恢复隐藏，不然的话保存进游戏也没有悬崖。

绘制这些地形的时候，可以用到Ctrl和Shift键

Ctrl [image] （点了一下，整张地图都变成暗色草地了）就像画图里的颜料桶。按住他点一下，一块区域就被这种地形全部覆盖了。

Shift [image] 你可以按住他，然后用鼠标拖动，就像画笔一样。

要注意！绘制地形在地图边缘的时候： 不要用Shift键，不然可能编辑器报错。其实就算你慢慢点也是有几率报错的。报错以后再载入地图还是上次储存的地图，

（本来想弄个报错的截图来着，可是怎么弄都不报错了 = =……这是有一定几率的……）

这几个功能最好不要使用。“自动建立海岸”，如果海岸线很曲折的时候会出问题。

“悬崖自动找平”从来没找平过……

“绘制悬崖后面/前部”只能画很直很难看的悬崖，而且在新城市地图里只能画城市悬崖。

爆开土堆打通道路

想必大家都见过这东西，打开这东西以后会变成一条路，需要特定的武器才能打开：

[HOWIZAP]

ROF=120
Range=6
Speed=100
Damage=4
IsSonic=Yes
Warhead=SonicWarhead
Projectile=Sonic;
这就是重点啦，土堆必须用声波武器才能炸开。
AmbientDamage=10

只要有一个拥有这个武器的单位攻击一下，土堆马上就开了。

地图上的火车和铁轨

当然首先要建立火车这个单位。在rulesmd.ini的[VehicleTypes]最后加入

85=train1; 火車頭

86=train2; 火車

87=train3; 火車尾

注册单位。Rules代码：

[train1]

UIName=Name:Train

Name=Train Cargo Electric

Nominal=yes

PipScale=Passengers

Passengers=2;载人多少个。自己决定。

Category=Transport

Strength=9999

Armor=light

Turret=no

TechLevel=-1

Sight=5

Speed=8

Owner=British,French,Germans,Americans,Alliance,Russians,Confederation,Africans,Arabs,YuriCountry

AllowedToStartInMultiplayer=no

Cost=800

Points=25

ROT=5

Crusher=yes

Crewed=no

Explosion=TWLT070,S_BANG48,S_BRNL58,S_CLSN58,S_TUMU60

VoiceSelect=CivAllSelect

VoiceMove=

VoiceAttack=CivAllAttackCommand

VoiceFeedback=

DieSound=GenVehicleDie

Locomotor={4A582741-9839-11d1-B709-00A024DDAFD1}

Weight=6

MovementZone= Normal

ThreatPosed=0 ; This value MUST be 0 for all building addons

DamageParticleSystems=SparkSys,SmallGreySSys

MaxDebris=5

DebrisTypes=TIRE,STAXLE

DebrisMaximums=4,2

Size=6

Trainable=no

DeployTime=.022

IsTrain=yes;决定这东西是个火车，各种火车的效应，例如撞坏轨道上的其他单位，不可以原地转弯。

MovementRestrictedTo=Railroad;让火车只能在车轨上行驶，车轨的添加将在下面提到。

ImmuneToPsionics=yes;不会被心灵控制。

ImmuneToRadiation=yes

MoveSound=huoshemovesound

SlowdownDistance=700

DeaccelerationFactor=0.001

AccelerationFactor=0.01

另外三节直接复制上面的修改就行了。之所以是三节，是有火车头，火车尾，火车中间车厢。这三节的图像不同。

Art代码：

[train1]

Voxel=yes

Remapable = yes

[train2]

Voxel=yes

Remapable = yes

[train3]

Voxel=yes

Remapable = yes

就够了。

然后加入素材。

加入铁轨：可以下载直接使用。

http://www.rayfile.com/zh-cn/files/f6abce17-74c2-11de-87d6-0019d11a795f/

下载完解压放到目录以后就出现铁轨等东西了。

然后设置车辆：

车头+几节车厢+车尾。

然后我们把鼠标对准第二节车厢，

地图编辑器左下角就会出现它的ID。然后双击车头，出现：

在“附属ID”里输入刚才看到的第二节车厢的ID就行了。如法炮制做到车尾。

这样设置的话，只要车头移动，附属ID的单位也会跟着移动，路径完全相同。

然后使用触发“建立小队”运行车头就可以了。当然车头的路径要用脚本设置。

地形的新增

很多制作者表示原版的地形太少了，而且不够华丽。其实制作者也可以新增地形。

1：TX地形包

http://www.rayfile.com/zh-cn/files/f6abce17-74c2-11de-87d6-0019d11a795f/

直接解压放到根目录就可以使用，之后你会发现编辑器多了许多地形。

2：自制地形。SunnyCase 的基础教程。

[TileSet0000]

SetName = Lat Grass

FileName = Clear

TilesInSet = 1

Morphable = true

LowRadarColor = 110,80,0

HighRadarColor = 150,110,0

RequiredForRMG = true

AllowBurrowing = true

AllowTiberium = true

TileSetXXXX XXXX的最大值为1000 必须为连续的你找到最后一个类似小结 在后面接上就行了
Set Name：就是在FA2里 地形/地表显示的名字
TilesInSet：就是在这个地形块里有多少类似(???01,???02)的tem/sno文件
FileName：文件名 后面跟数字 数字的最大值为TilesInSet里设置的 FA2在寻找的时候会按???01.tem.???01a.tem ???01b.tem... ???02.tem...???03.tem,???03a.tem,???03b.tem...寻找

就TileSet0000来说：原版总共有的文件是：clear01.tem clear01a.tem一直到clear01g.tem
但是TilesInSet只填1 也就是说FA只认数字的最大值 后面的字母不管
AllowTiberium：是否允许上面放矿


其他

常用代码

声音

1：NukeSiren 核弹警报

2：Bonus 哔哔

3：Test1（1-10）可用作倒计时，不过经常会被其他声音盖过去

语音

1：EVA_EstablishBattlefieldControl

建立战场控制，请稍等。（任务开始通常播放的）

2：EVA_BattlefieldControlOnline

战场控制连线。（47 允许用户输入 时播放）

指示箭头动画：

向下，时间较长 ： 475

向下 483

向左 482

向右 481

向上 480

左上 479

左下 477

右上 476

右下 478

任务制作者常用的[General]的代码

CampaignMoneyDeltaEasy=5000 ;简单模式设置，这样会比地图所属方里设置的多5000

CampaignMoneyDeltaHard=-5000 ;困难模式设置，这样会比地图所属方里设置的少5000

后者因前面有一个减号，当然困难模式加钱也是可以的。

BuildSpeed=.3 ;建筑建造速度，每画一千元用多少分钟。可以用来调节建造速度。


小队

刷兵

建立小队

调动该国家的空闲单位组成指定小队执行命令（无视空投属性），当空

闲的指定单位不足时：

1.如果该参战方是电脑控制，则电脑会征用工厂自动建造该单位，直到

满足小队成员为止。

（限制科技等级小于10，负数也算。），当工厂已经被征用时，此小队

不会建立。

2.如果该参战方是玩家控制，则不建造该小队，只会调用已存在单位。所调用的单位是距离“作战小队”所写的路径点 [image] 最近的单位。默认是0.

3.如果该小队有编号，那么建立小队时只会调用有该编号的小队。

如果需要调用有编号的单位，可以使用以下方法 by：ROCKMAN：作战小队中的“分组”设定为-2。

但是建立的同时，将会取消玩家的编号。还要在作战小队里选上“消除威胁”（让该单位切换目标，不再攻击目前的威胁），不然可能出问题。

7援军

在作战小队所写的参数路径点上刷出该小队。

如果改小队是空投部队，则该小队会被空降到该路径点，运输机会在作战小队的参数“传送路径点”出现。如果没填“传送路径点，则在这个作战方的边界处随机出现。

如果不是空投部队，则小队会突然拥挤的出现在该路径点。

80援军（在路径点）

在指定指定路径点刷出该小队

可以指定空投部队，此触发的路径点数据会覆盖作战小队中的参数“路径点”

其余和“7 援军”相同。

107 超时空传送援军...

在指定指定路径点用超时空效果刷出该小队，小队成员会整齐地出现，并不会拥挤地出现。

指定空投小队不会出现运输机，而小队成员直接超时空刷出。

自动补充小队成员:

当勾选“增援小队”时，小队成员缺损后会自动补充。

补充方式遵循"4 建立小队"。

当小队被完全摧毁时不再补充。

自动建造与基地节点

相关触发

3 开始生产 ：允许建造步兵，坦克等单位，包括建立小队空闲单位不够时。

【是否包括AI出兵还未证实】

13 自动生产开始：这个翻译和作用完全不沾边..这个触发真正的作用是，当建筑被攻击时

自动调用空闲单位去灭掉侵略者。【灭掉后是否会回到原来的地方未证实】。

30 自动建设基地：开启自动建造模式，当有预设建筑时无法开启...

74 AI触发开始：当首次发生战争是开始按照AI出兵，当“忽略全局AI”为NO是按照AI.ini

和地图AI出兵。

30 自动建设基地 是 否

只用于该触发所属方的这一个所属方，电脑将按照科技树顺序自动建设基地建筑、防御工事。

当然看上去可以随时用触发启动或停止。

节点建造限制

1.默认为限制状态。

1.在限制状态下只有电量远大于用电量电脑才会建造节点。

2.电脑一旦用节点建造了一个电站，那么限制解除。

预设建筑的建造与该国家是否开启 3开始生产 等，和是否忽略全局AI无关，只要有建造厂

有足够的资金都会建造，顺序是按照节点的ID（按放置节点的顺序）。

在扩建地图时基地节点会漂移，此时可以写字板打开地图搜索相应的作战方，清除节点再来一次。

AI出兵

在任务里用AI建立小队是很明智的，因为用触发建立小队过于死板，又不好控制。

AI则可以解决这些问题。

首先，禁止旧的AI触发

编辑——基本设置——忽略宏观（全局）AI控制=yes

这样，所有电脑都不会按照原版AI.INI里的设定建造部队了。当然如果你只是想让电脑

在原来的基础上增加几个小队就不用禁止了。

然后，任意建立一个小队，脚本，部队，作战小队像普通小队一样，但要注意以下几点：

1：作战小队里的参战方是没用的东西

2：作战小队里的路径点不要填写

3：地图上，该电脑至少有一个拥有“基地防御”的小队存在于地图，最好能够是

防御基地的。最好选上“可为小队重组成员”保证被消灭以后会再补兵。

如果没有的话，那就不能建造其他AI小队了。

特遣部队，即使不是本国的单位也可以造出来。

AI注意：

AI触发下面的“允许”一定要勾上，除非你没有禁止“全局AI控制”

小队类型可以关联两个，这两个小队都会出来，按照作战小队里的脚本进行。

这样可以保证两个小队同时建立。

分量：数值越大，建立几率就越大，分量大的比分量小的AI先建立。

其他触发什么的都很简单，这里不说了。

触发：

3 生产开始...

13 自动生产开始...

74 AI 触发开始...

以上三个触发都运行才能保证出AI无误。

如果想让电脑出原版AI的小队并且自动造建筑还需要：

30 自动建设基地…

AI单人任务的INI设置。
为了防止任务中AI不脑残（像是疯狂造尤里矿车、出兵响应时间太慢等被灭了还没出兵），你可以在地图内加入以下这些

[AI]
AALimit=5
TeslaLimit=5
AttackDelay=0.1
BaseSizeAdd=1
DefenseLimit=10
PowerSurplus=1500
AIBaseSpacing=2
AttackInterval=0.1
AutocreateTime=1
PowerEmergency=50%
TiberiumFarScan=50
TiberiumNearScan=6
ThirdBaseDefenses=YAGGUN,YAPSYT,NATBNK
AlliedBaseDefenses=GAPILL,ATESLA,NASAM
SovietBaseDefenses=NALASR,NABNKR,TESLA,NAFLAK
AIForcePredictionFudge=80,80,80

[General]
AISafeDistance=40
SlaveMinerShortScan=256
SlaveMinerSlaveScan=256
TeamDelays=200,200,200
AIHateDelays=15,15,15
TotalAITeamCap=60,60,60
AISlaveMinerNumber=1,1,1
AIVirtualPurifiers=8,6,4
PrismSupportModifier=150%
AIRestrictReplaceTime=100
ThirdBaseDefenseCounts=25,25,25
AlliedBaseDefenseCounts=25,25,25
SovietBaseDefenseCounts=25,25,25
AIPickWallDefensePercent=50,50,50
DissolveUnfilledTeamDelay=500
DisabledDisguiseDetectionPercent=100,50,25

注意点：

地图上，该电脑部队至少有一个拥有“基地防御”的小队存在于地图才能保证它的

其他AI部队正常建立。如果没有，电脑将不会建立其他的AI部队。

AI出兵的顺序是：基地防御-其他-侵略性的小队

聪明的电脑矿车（by：yuri助手）

不知道我们敬爱的制作者在针对控制某电脑参战方矿车的数量时，有没有注意过一个恼人的问题：

rules里预设的iq等级所做的这一方面的努力非常有限——电脑不是不停地造矿车，就是造很少的

矿车，总之预设的程序会尽力让你不满意的，现在，就尝试改变这种局面吧。

请跟着以下指导进行操作：

1、建立特遣部队：1个矿车，当然是你想要的那个阵营类型的……

2、建立脚本：do this-area guard （这个是防止电脑过于弱智造成矿车堵在工厂门口的情况）

3、建立小队：用上前面所述的东西，路径点留空，最好设立参战方（不解释），优先级最好高一点。

4、建立触发-类型2（重复）-事件48-行为4-把刚才的小队编进去

5、最重要的一步，再打开步骤3建立的小队，你会发现没填“标签”，那么，把步骤4的触发填进去。

6、你最好在地图上先放上几辆矿车，比如我放了3辆，那么现在就把第四步建立的触发关联上去！

这样，不论你怎样消灭电脑的矿车，他们总会保持在三辆。

就可以发现，这个小队队员即使只关联一个触发，也可以做到全灭后重新建立。

给脚本取中文名

很多中文字符不能用于脚本，不然的话会变成乱码。但是有办法防止。只要我们把中文脚本名称两侧都加一个英文字母就可以了。

这样的名称就不会变成乱码。小队，特遣部队也一样适用。

设置变量

该脚本常常被认为是无用的脚本，其实用处非常大

在某个小队到达某路径点以后，可以用这个触发进行确认。

作战小队中的选项

可装载 一般都设为No，如果部队中有成员需要Reload的(例如弹药ammo=)就设为Yes

空降部队 该小队将会由运输机空降，飞机出现点为传送路径点，空降点为路径点，触发出兵专用

自动建造 AI出兵专用。不知道为什么，选了这一条会阻碍单位执行走出地图的脚本，所以运输船撤离一类的不能选中这个。

完整小队 有此标签的小队将会由可装载的单位装载所有该小队的单位，触发出兵专用哀叫效果

预建造 AI是否在还没需要时预先建造此队伍

可为小队重组成员 YES=若当前的部队完成任务后还有剩余单位,将会加入另一队中。默认为no

烦恼效果 yes是使AI的部队攻击完后撤退,并且待会再次发动攻击

解散新兵 决定部队是否在完成script type定义的任务后解散,而且不会再作为新兵加入其他队伍

增援部队 设置此部队是否为援军。多数用于守卫的部队会设成Yes，基地被攻击后这个小队会赶过去。

装载器卸载返回 设置运输单位是否在完成卸载时返回基地

防卫减缓 部队在基地中作出还击时反应不会变慢

侵略性的 用于侵略的小队，一般AI会在达到一定防御建筑数后才会出这个小队，AI出兵专用

只为传送

基地防御 AI会先出这个小队用于防御基地，如果一个AI防御小队都没有他就不会出其他部队，AI出兵专用

补充新兵 AI会动用现有的单位去组成或补充队伍（如果这个小队未被全歼，那么AI会补充这个小队损失的单位。）,优于去建造新的单位来组成队.就是强制解散那些优先级比较低、设置了可为小队重组成员的小队并重组其中的单位。

自毁单位 设置此部队是否忽略任何攻击并继续前进,常用于战机和运输船

消除威胁 小队成员在移动的过程中将会试图规避途中可能遭遇的敌方单位（如果这个小队里的单位下一个目标是走到地图边界之外，那么这条选项无用，他们不会躲开敌人。）

只攻击目标敌方 是否只对付敌对玩家的单位,而不攻击中立的单位(neutrals阵营的)

运输船动作

1：当小队选定了“完整小队”时，小队里其他单位将会直接装在载具中。

不受空间大小限制，一个运兵船可以装载无限的单位

2：如果是电脑建造的小对，选择了“完整小队”电脑将会把建造出的单位

装进载具。如果小队里单位过多，无法装载全部。将会停止装载，这个小队

将无法执行。

3：小队选择了“传送器卸载返回”，载具将在卸载以后自动返回基地，还

可作为下次小队的运输单位。前提是在卸载脚本中使用2或3（2：保留小队T

除载具 3：把小队和载具统统T除）为其他选项时，“传送器卸载返回”无用

☆Load on to Transport:

小队中成员互相装载（如果可能），不能装载的单位将被能装载的单位装载。

☆Unload:

卸载所有单位，具体参数如下

0-保留交通工具和货物执行命令

1-保留交通工具，把货物T出小队

2-把交通工具T出小队，保留货物

3-交通工具和货物都T出小队

4：若想让运输载具离开地图消失，则不能在这个载具的作战小队里选中“自动建造”，否则载具不会离开地图，只会原地不动。


创意

自动更改光照

使用触发结果

142 重绘红色

143 重绘绿色

144 重绘蓝色

可以在任务半途重新自定义地图的ＲＧＢ。

而使用

71 设置环境步幅... （一般使用1020000000）

72 设置环境速率... （一般使用1036000000）

73 设置环境亮度...

可以改变光照亮度

你可以用这几个结果组成触发组，使地图上的光照随时间的改变而变化。

心灵震荡的光照

除了光照设置里面的参数之外，你还可以写字板打开地图找到

[Lighting]

DominatorRed=0.000000

DominatorBlue=1.500000

DominatorGreen=1.000000

DominatorLevel=0.000000

这是超武“心灵震荡”时地图上的光照。

黑暗空间

当光照设置里面的ＲＧＢ都为０而光照为１时，你会发现地图上的地形都变黑了，而单位和建筑却能看得见，这样可以营造一直神秘的空间的效果。

在地图里下雨

by：МК

;武器，关联到单位上使用。

[AcidMissile]

Damage=1

ROF=300

Range=4

Projectile=AcidPr

Speed=70

DecloakToFire=yes

Cursor=ThunderStorm

Warhead=AcidStart

Report=WeatherStrike

Burst=1

[AcidPr]

Arm=2

Shadow=no

Proximity=no

Ranged=yes

AA=no

AG=yes

Image=INVISO

ROT=100

SubjectToCliffs=no

Airburst=yes

AirburstWeapon=M60

SubjectToElevation=no

SubjectToWalls=no

[AcidStart]

Wall=yes

Wood=yes

CellSpread=1

PercentAtMax=1

Verses=100%,100%,100%,100%,100%,100%,12%,10%,8%,100%,100%

Conventional=yes

InfDeath=7

AnimList=ACIDRAIN

ProneDamage=50%

PenetratesBunker=yes

;***art***

[WCCLOUDA]

Rate=375

Image=INVISO

Layer=Top

LoopCount=5

AltPalette=yes

Trailer=DropAcid

TrailerSeperation=8

TrailerAnim=DropAcid

SpawnDelay=8

[ACIDRAIN]

LoopCount=999999

Trailer=AcidCloudS9

TrailerSeperation=8

TrailerAnim=AcidCloudS

SpawnDelay=3

[DUMMYIMG13]

UseLineTrail=yes

LineTrailColor=255,255,255

LineTrailColorDecrement=200

[DropAcid]

Elasticity=0.0

MinZVel=1

MaxXYVel=1

Damage=0

DamageRadius=100

Warhead=SA

IsTiberium=true

Image=DUMMYIMG13

LoopStart=0

LoopEnd=8

LoopCount=-1

Rate=500

RandomRate=220,500

Bouncer=yes

[AcidCloudS]

Elasticity=0.0

MaxXYVel=300

MinZVel=300

Damage=20

DamageRadius=80

Warhead=HARMLESSWH

Image=INVISO

LoopStart=0

LoopEnd=15

LoopCount=-1

RandomRate=220,600

DetailLevel=0

TrailerAnim=WCCLOUDA

TrailerSeperation=8

Bouncer=yes

这个武器只要发射一次，地图上就会不停的下雨……。你需要一个空的SHP，叫ACIDRAIN。不然的话雨不会一直下的。


创意

极略

RPG形任务，有两种。

一种是传统型RPG任务。即玩家在游戏中扮演一个角色，整场游戏几乎只控制主角。

而另一种为副本型RPG任务，需要玩家操纵几个有不同能力的主角，配合完成任务。

BOSS战

BOSS战为RPG任务里面的重要元素，典型的任务是ROCKMAN的迷系列任务，最终BOSS厉害无比，玩家要靠头脑战胜它。

没有了BOSS，玩家只能虐虐杂鱼，失去了RPG任务的最主要的乐趣。

BOSS可以拥有通过触发/INI做出来的各种奇怪的能力让它不同于小兵，玩家必须通过特定的渠道才能打败之。

字幕

RPG任务推动主要剧情的是字幕（就是上方显示的文本）而不是剧情说明，字幕可以写成对话的形式，每隔20秒就播放一条字幕来构成剧情对话。

背景音乐

游戏中随着战斗/剧情的变化，使用触发不停变换背景音乐，使其符合剧情也是不错的。


单位

BOSS单位

RPG任务中的BOSS必须非常特别，以至于使其与杂鱼不同。以下提供几种创意单位

1：不同武器攻击的单位：by：ROCKMAN

使用盖特逻辑可以做到间隔一些时间换一个武器。

盖特逻辑的代码：

IsGattling=yes ;不用多说

RateUp=xxx ;此项一般为1，到了时间立刻切换武器

RateDown=xxx ;盖特武器上下“档”时的延迟，此项数较大时停火很长时间也可以恢复到原来的状态

Stage=3 ;阶段数（一般为3，好象有上限）

Stage1=xxx

Stage2=xxx ;开火XXX时间后加强火力

Stage3=xxx

EliteStage1=xxx

EliteStage2=xxx ;精英级别开火XXX时间后加强火力

EliteStage3=xxx

GattlingWeapon1=（好像是这个词？？忘了 参考盖特坦克吧）XXX ;一阶段对地武器

GattlingWeapon2=XXX ;一阶段对空武器

3和4为二阶对地对空，56 三阶（多节以此类推）

盖特武器的目标限制（即Verses）由一节对地武器来决定

还有不要把盖特武器放在多炮塔坦克上，动画炮塔（光凌，监狱）的也不行

2：同时使用不同武器攻击：By 蜘蛛星云

首先建立所有你想要的武器，各个放在一个单位上。建立一个容量超大的战斗要塞形单位，即装进去的东西可以对外射击的单位。

只需要在任务中使用建立小队让所有“武器”装进这个战斗要塞，便可以做到同时发射许多种武器。且可以做到不同射程不同武器。

子机：游戏《宇宙巡航机5》中，主角可以召唤子战机。子战机会跟随主角移动，攻击。RA2里也可以做到：

1：主角，随便什么的单位都可以。设其归属为A国

2：子机，一个战斗要塞，可以装进去东西。有一个没有威力而且看不出来什么东西的武器，且只攻击主角。这样就做出了子机跟随主角。（如何只攻击主角方法有很多，例如这个武器只能对付主角的装甲，或者用触发“成为敌人”做到宣战效果）开始游戏让几个士兵坐进去，这几个士兵的武器要求不能对付主角，否则就会光顾着打主角，忽略其他敌人了。

结果：主角出现，子机为了攻击主角（可用触发“6 全部搜索”，也可调节子机的模式为Hunt）做到了子机跟随主角。遇到敌人以后，子机里坐着的武器攻击敌人。

3：不同武器攻击不同敌人By 终幻

使用盖特火炮逻辑可以使坦克具有3个甚至6个武器。

以天启为例，让天启对步兵用机枪，对坦克和建筑用火炮，对飞机用导弹，对飞行兵用防空炮：

首先删除天启的主武器和副武器

Primary=120mmx

Secondary=MammothTusk

ElitePrimary=120mmxE

EliteSecondary=MammothTusk

然后加入以下语句

IsGattling=yes

TurretCount=1

WeaponCount=6

Weapon1=Para

EliteWeapon1=ParaE

Weapon2=MammothTusk

EliteWeapon2=MammothTusk

Weapon3=120mmx

EliteWeapon3=120mmxe

Weapon4=FlakGuyAAGun

EliteWeapon4=FlakGuyAAGunE

Weapon5=AGGattling3

EliteWeapon5=AGGattling3E

Weapon6=Flakweapon

EliteWeapon6=Flakweapon

WeaponStages=3

Stage1=1

Stage2=999999

Stage3=1

EliteStage1=1

EliteStage2=999999

EliteStage3=1

RateUp=1

RateDown=1

接着修改FlakGuyWH和ApocAP（ApocAPE）弹头为

Verses=150%,100%,50%,0%,0%,0%,0%,0%,0%,0%,0%（只对飞行兵）

Verses=0%,0%,0%,100%,100%,100%,100%,100%,70%,60%,0%（只对坦克和建筑）

还要让Para的弹头SSA加入：

Wall=yes

Wood=yes（不然天启不砍树和围墙）

作用原理：在遇到地面部队时，天启会用武器1锁定（所以Para的弹头SSA必须对坦克），在对抗坦克时，天启会立刻进入武器2攻击状态（使用火炮），而对抗步兵时，由于武器2的弹头（ApocAP）不对步兵，所以天启会恢复武器1攻击状态（机枪），对空同理，加入6武器同理。

当然最后还是要调试一下。

如果适当的修改RateUp和RateDown外加武器1和武器2具有类似的弹头，则可以做出双武器攻击的效果（如：象将军的天蝎坦克那样先发射反坦克导弹，然后用火炮近战）


创意

标识物

1、 任务中拿到书籍的设置：可以设置一个建筑在玩家防御界面，让玩家不能在任何地方建造。这个建筑的名字可以输入书籍的内容。玩家可以进入防御界面观看书籍，做到“侦探型”游戏。不过字数有限要注意。

2、 钥匙设置。玩家需要到达某个地方拿到钥匙，开启变量，才能到另一个地方开门。钥匙也会出现在防御界面，意为“已经得到钥匙”。

（上面两个都是赛特亮大师在FK里“月光宝盒”里出现过的，你也可以从那里拿素材……鄙人也做了一个书本的素材——偷懒用记事本图标做的QAQ。拿到以后可以做到钥匙消失，书本消失什么的。）

3、 按钮。玩家可以点击按钮建筑，进而选择分支任务，或者选择跳过片头介绍什么的。（鄙人曾经做了个按钮，不过比较难看QAQ，若有意者可联系本手册里唯一的邮箱。。。）


创意

弹幕射击

一个好的RPG任务中，当面对BOSS时不应该只是单调的伤害输出，BOSS应该有“能被闪避的攻击”。这种攻击叫做“弹幕”，玩家需要适当地闪避弹幕，避免被击中过多的弹幕挂掉。以下来举例几个比较常用的弹幕：

1、 高抛射弹：武器Lobber=yes。抛射体Inaccurate=yes，Arcing=yes。不精确的武器，当玩家快速移动时，此武器打不中。此外，也可用NPext设置不精确值。

2、 卵导弹：使用NP的自定义功能新建导弹，而导弹只能攻击最先瞄准的地方。可以使用瞄准线来提示玩家。

3、 垂直下落弹：抛射体Vertical=yes。把这个武器给BOSS旁的近卫的卵飞机，让其久不久盘旋在玩家上空扔炸弹。

4、 流星武器：打出一个流星，玩家要在流星砸到之前闪开。

5、 直射弹：抛射体CourseLockDuration=-1。这种武器一旦开火不会停止移动，因此你得加上不能穿越悬崖什么的来阻止它。这种武器可以通过尾焰产生伤害。

6、 回转弹：抛射体CourseLockDuration=120。上一个武器的变式，效果是飞出去一段时间后会自动折返。


创意

分支剧情

RPG任务有一大特色就是拥有剧情分支，我们可以用以下方法来营造不同的分支的剧情。

1、 用局部变量的开与关来判断玩家是否已经触发了相应的剧情。

2、 用任务计时器的是否超过时间判断玩家进入哪一个剧情。

3、 用无限关联触发来使一个单位在不同的情况下在一个对象上拥有不同的剧情。

4、 用重复的触发每一秒钟增加一个计时器单位，可以做到让计时器暂停。可以做成“剩余目标数量”什么的，每当摧毁一个目标就减1秒钟，当计时器为0时触发条件。

5、 用完成某个任务后刷出一个判定用单位的方法与条件60 科技类型存在，可以做到数量的判定。

上面的理论比较难懂，以下举一个实例：例如根据“久不久就要吃饭，不吃饭就会饿昏”的触发系统，可以有以下的剧情By 九顺：

当男主角找食吃时，可以选择区菜市场买菜自己煮或者是上饭馆。

这样又会邂逅卖菜少女或者少女服务员。而如果不去找食吃的话男主角会饿昏在路旁，又会触发被好心富家女主救起的剧情。

这里利用了3个局部变量来使其判断你能认识什么人。而吃饭系统运用到了计时器和局部变量。需要注意的是这里的分支是一定会触发的。

有了剧情后会有各种奖励，比如被富家少女救起后可以过一会得到金钱援助。

有了钱后你还买不到东西必须有关系，例如说跟军火商关系比较好才能买到光棱坦克。而你得翻过山头在几个城市里面做跑路任务才能拉到关系。

这里是局部变量和无限关联触发的进一步运用，当某个局部变量被开启时，一些事件会不同。

如果不吃饭，后几次快饿晕的时候，剧情会强制男主发生剧情，直接去蹭饭，而富家少女会很热心地给饭吃。

做一些富家少女给的支线任务，加好感到一定程度，富家少女就会告诉男主一些事情，同时寻求帮助。做完这些委托能大大增加好感度。

好感度的数量可以用条件60 科技类型存在的数值来判断。而好感度每+1，就直接刷出一个判定用的单位。

等事件到了一定的量，会触发大灾变剧情，城市被光头尤里入侵。几个女主分散到不同的地方。根据你的好感度高低来判断你进入了哪一个女主的支线。最后就是不同的结局了。

这里就是前面的综合运用，就不多废话了。

这里并不是提供剧情创意，而是告诉你类似的分支到底如何用触发实现，上面的例子提供了分支剧情的各种思想。

当然，你可以把富家少女改成罗曼诺夫，而主角是忠心报国的特种兵，etc。

熟练地运用分支剧情可以让玩家为了完成不同的支线重复玩这个任务，可玩性大大增加。


创意

副本小队

在这里介绍副本型RPG任务的一种比较好用的组合。

１、Ｔａｎｋ

在小队里负责抗怪的角色，承受大部分敌方伤害。

可以是血多回血快的，并且能有效吸引敌人的仇恨，让敌人在其存活时只攻击它。

当Ｔ被干掉后，敌方会将目标转移向其他脆弱的小队成员，进而导致团灭，任务失败。

Ｔ不需要太多，１个就够了，比较少的Ｔ可以锻炼玩家操作。

当Ｔ比较比较理想的角色是黑洞装甲ｂｙ　ＭＫ

代码：【略】

２、治疗

在小队里负责回血的角色，主要在Ｔ抗怪时治疗之使其不能轻易挂掉，与治疗不慎被伤害的小队成员。

当治疗被干掉后，Ｔ与其他成员将得不到有效的回血，进而导致团灭，任务失败。

此外，治疗还可以拥有铁幕附加等增益型技能，提升队员生存能力。

治疗根据敌军输出设定不同的数目，但一般１～２个就够了。

一般采用可远程维修的维修车作为治疗

代码：复制维修车的武器，Range调大，用一个普通坦克换上。

３、ＤＰＳ

在小队里负责攻击的角色，负责大部分伤害输出。

当DPS被干掉后，敌军单位将不能快速地清理，Ｔ与其他成员将面临超过负荷的敌军围攻，进而导致团灭，任务失败。

DPS是小队中最多数量的成员，根据任务的不同，一般为2~4个。

此外，DPS也可以是T。

DPS的形式多种多样，能有效制造伤害的都为DPS。

不过不应该把DPS的伤害设置得过高，否则秒杀敌人，就失去了任务的趣味性。

４、侦查

在小队里负责摸清地图，拉怪的角色，一般速度较快，视野较广。

侦查可以让小队保持一个最佳的应对状态。

此外，侦查也可以并非独立的职业，DPS、T也可以作为侦查。

５、特殊

在小队里负责通过任务特殊关卡的角色，比如说炸掉路障、打开大门等。

同理，特殊也可以并非独立的职业。


创意

换装

单位更换装备/换衣服。这原本是赛特·亮大师在FKOL任务《中国不需要征服世界》里用到的。

即单位（可以类似间谍）进入某建筑（可以被间谍进入）触发事件，几秒钟后援军出来另一个单位。当然你要通过INI设置来达到只有这个建筑能被该单位进入的效果。

此外，还有另外一个创意By 蜘蛛星云：如一个步兵单位弹药可以有限，RA2平台的BUG，即步兵单位如果限制弹药，那么用光弹药后，不被攻击一下是不会自动补充的。

在RPG任务里可以用到。给他弹药限制，然后可以用上面的方法。

鄙人还想到了另外一个东西：可以用NP的变异升级，让他进入训练类建筑升级变成另一个跟这个单位完全一样的单位，那样就可以补充弹药了。

不过NP变异升级也许不可以关联本身的单位（即动员兵升级再变成动员兵是有可能出错的。），所以必须得让他升级成一个和原来一模一样的单位。

再推一下，我们可以用NP的变异升级做到换武器。即A（机枪）单位进入训练中心以后升级变成B（火箭炮）单位，B单位进入训练中心变成A单位。


创意

抢车

像侠盗飞车那样，主角进入小车就可以开车，出来就不能控制车辆。限制是只能控制一名角色。

先介绍第一种方法：By：冰天雪地

除了平民还需要两个所属方

Player：主角的所属方

Car：可操作的小车。

这两个所属方都可以被玩家操作，而且互为盟军。

触发设置：

触发1：进入事件 改变所属方为Car，建立小队A，允许触发2，禁止触发1。（重复触发）（允许）（关联到小车）

触发2：被任何事物摧毁 允许触发3，禁止触发2 （重复触发）（禁止）（关联到主角）

触发3：任何事件 Car全部改变归属为平，禁止触发3，允许触发1 （重复触发）（禁止）（不关联）

小队A：

编号为-2

成员是主角

脚本：

1：改变归属为平

2：等待1秒

3：改变归属为Player

这个效果解释一下就是：

主角进入小车，小车变成玩家可以操作的Car国家。同时建立一个让主角改变归属的小队。如果主角改变归属，触发就会当作主角被摧毁，然后让Car变回平民。但是主角进入小车无法建立小队，所以只有主角从车里出来才会触发。就可以做到效果了。这个方法的优点是用触发就可以完全实现，但是由于每次建立小队都会使编号消失，因此弊端是玩家无法给英雄单位编组。

鄙人想到的是另外一种方法，改变一种判定方式，让主角可以编号。

我们可以再新增一个所属方Attack’，让他仅与主角为敌。

触发1：进入事件 改变归属为Car，禁止触发1，允许触发2。 （重复）（允许）（关联到小车）

触发2：受到攻击 允许触发3，禁止触发2。 （重复）（禁止）（关联到Attack的单位）

触发3：任何事件 允许触发1，Car全部改变归属为平，禁止触发3。 （重复）（禁止）（不关联）

解释一下就是：

Attack这个所属方有一个特殊单位藏在某个角落里，不停攻击主角。但是他的武器只能在攻击的时候打到自己。在主角进入小车以后，他就不会攻击自己了。我们允许一个触发，让他只要打自己，就会让所有Car变成平。所以主角从车里离开后，这个单位继续攻击自己。当然你得一直给他加血。


创意

室内

可以用悬崖或围墙，营造似乎在室内的样子。

可以通过超时空转换实现场景的转换（出门啊，上楼啊什么的）。


创意

极略

战略任务的形式多种多样，玩家需要调动大量部队来完成的任务都可以叫做战略任务。

盟友

一个战略任务中，盟友是属于玩家不能操控的，但是盟友的情况好坏又会影响玩家的战况。

一个有可玩性的任务，盟友的强弱应该在　没有玩家的帮助时盟友处于弱势——有了玩家的帮助后盟友可以有效玩家的战斗力　之内。盟友太弱就没有了存在的必要性，而太强又没有玩家的发挥空间，除非你有特殊的用意。

盟友未必是帮忙的，可能是突然出现来裹乱的。例如如果盟友比你更快攻略敌人基地，会先抢占敌人的油井，而你就不能占领了。但是放在地图上的助战盟友基地最好不要这样，那样的话盟友的存在就没有意义了，除非你想趣味一点。

建筑的摆放

许多任务里可以看到这样的情况，地图上一堆一堆核子反應爐用来供电，一排一排防御工事浪费你的时间。

这样任务对于刚玩任务的人来说也许很有趣，但是玩久了就觉着没意思了。

作为任务制作者，现在我们需要尽力避免刷建筑的情况。

不同派别不要有其他派别的建筑，就像盟军不要有核子反應爐一样。除非你的剧情可以解释这是为什么。

防御建筑不用摆放太多，太多会让人看起来恶心。基地里的防御建筑不要摆放的很密集，一排一排的这是围墙还是防御？

不要有太多建筑，即使你的任务不是消灭所有敌人，不然的话玩家也会感到不适。

没必要到处都是光棱塔，用“路过”的单位防御也很好。

哨戒炮什么的不是没用，装饰也好啊，总好过所有防御都是光棱塔。

字幕与剧情说明

战略任务推动主要剧情的是字幕（就是上方显示的文本）与剧情说明，字幕可以写成对话的形式，每隔20秒就播放一条字幕来构成剧情对话。而剧情说明处也可以写点攻略提示什么的。

背景音乐

游戏中随着战斗/剧情的变化，使用触发不停变换背景音乐，使其符合剧情也是不错的。


指挥官技能

By 蜘蛛星云

释放技能吧指挥官！

每个国家都可以有自己的特殊属性。

初始的为一级,可多设

VeteranInfantry=GHOST,SNIPE

VeteranAircraft=ORCA

VeteranUnits=FV,CARRIER,SHAD

建造时间为原来时间的0.5倍

BuildTimeInfantryMult=.5

BuildTimeAircraftMult=.5

BuildTimeUnitsMult=.5

BuildTimeBuildingsMult=.5

BuildTimeDefensesMult=.5

速度为原来的1.5倍

SpeedInfantryMult=1.5

SpeedAircraftMult=1.5

SpeedUnitsMult=1.5

单位花费。设置这个就打掉一个敌军单位直接3星

CostInfantryMult=.5

CostAircraftMult=.5

CostUnitsMult=.5

CostBuildingsMult=.5

CostDefensesMult=.5

血量

ArmorInfantryMult=2.0

ArmorAircraftMult=2.0

ArmorUnitsMult=2.0

ArmorBuildingsMult=2.0

ArmorDefensesMult=2.0

这些代码加入某个国家里，就可以赋予这个国家这种能力。

这样就可以做出在任务中赋予敌人特殊能力。

我们可以使用“全部改变所属”来让敌人增加能力，比较生僻的用法是给英雄单位改变属性，或者提升某个单位的属性。

我们尽可以在游戏中提升难度，让玩家每灭掉一个敌军基地就增加一定难度，或者在玩家部队虚弱的时候增加敌军单位速度。适当的搭配可以让游戏可玩性大大提升。


创意

反作弊

１、玩家在金钱多余任务设置量时，任务失败。

２、在不该有电的游戏里玩家电力充足，任务失败。

３、某个建筑建立以后进行计时，如果第二个建筑建造过快，任务失败。

４、用全局变量，任务完成时设置，第二关需要这个全局变量才能运行，可做到反跳关。


创意

生化危机模式

用NP的新变异狂兽人设置，可以新增一个生化兵。

让生化兵的武器是变异武器，即攻击另一个步兵，这个步兵也变成生化兵。做出生化危机效果。

再从《生化危机》一类游戏里提取写语音就更好了。


创意

时空门

从这里进去的单位可以超时空到另一个地方。

我们可以做一个超时空的载具坦克“作为电梯”，在有单位进入以后，用小队超时空到目的地，再释放。

这个可以作为ＲＰＧ任务的英雄转移，或者战略任务的部队转移。

此外，可以把时空门的移动模式改成车辆或者飞行，做成车站或者飞机场的效果。